• Can't post after logging to the forum for the first time... Try Again - If you can't post in the forum, sign out of both the membership site and the forum and log in again. Make sure your COG membership is active and your browser allow cookies. If you still can't post, contact the COG IT guy at IT@Concours.org.
  • IF YOU GET 404 ERROR: This may be due to using a link in a post from prior to the web migration. Content was brought over from the old forum as is, but the links may be in error. If the link contains "cog-online.org" it is an old link and will not work.

Kentucky Kick Down 2017

Bud

Member
Member
Went to the Kentucky Kick Down on Barret Ave in Louisville today.  I spotted a black C14 parked next to a maroon C10 in one of the parking lots.  Was riding my 05 with a madstad.  Possible COG folks?  There were some pretty Z1's.  Saw a RD400 Daytona Special...really nice!  Saw a really nice old Ninja 750 Turbo.  There were a couple of really nice really old Indians.  I don't remember seeing any old GS1100's in any form.  Maybe I should go back tomorrow and show my GS1100GK.  I guess with all it's imperfections you'd call it a survivor.  I've had that one since 91, so it's just about a member of the family.
 

Attachments

  • 130813_001.jpg
    130813_001.jpg
    178.3 KB · Views: 12

DeansZG

Street Cruiser
Forum Subscriber
Nice GK ! 

Had an '82 GS1100GZ for a # of yrs. before I bought my C10 back in '99. 
 

Bud

Member
Member
Thanks for the compliment!  Suzi and I have a long history.  Sometimes we're in love and sometimes we're fighting.  I have to take responsibility for being somewhat of an ignorant owner.  I've probably learned more about this bike in the last 5 years than I did the first 20.  She runs great.  I replaced the starter clutch and gear with a brand new one.  She has a brand new stator and an upgraded reg/rectifier (CanAM) so no more charging system problems.  I just replaced the petcock with a new OEM the other day.  This is also the first bike that I've ever had the top end off of.  As SISF has said: "If you think you can do it you probably can".  He is right about a lot of things....including that! :great: :motonoises:
 

DeansZG

Street Cruiser
Forum Subscriber
Oh yes, I forgot about those charging issues ;D  I do recall one long wknd trip had the wife & I returning north thru the Cincy / Dayton area w/ the ambient air temp around 95 with the humidity about the same %...  Anywho, after one of the many re-hydration stops that day, discovered the stator assembly had dislodged itself from the crank taper, meaning that I had to push start the bike(along w/ the luggage strapped on it).... got lucky, as the crank only had one or two minor scratches on the taper which were polished out after the trip. 
 

Bud

Member
Member
I'm guessing you mean the starter clutch?  The stator attaches to the inside of the LH cover on the engine.  The starter clutch goes on the tapered end of the crank and is held on with one big bolt.  That had to have been making some racket!  You have my sympathies regarding all the bump starting of a fully loaded bike.  Not my idea of a good time for sure!  The first charging system problem I had on this bike, I was on my way to a family reunion in MO.  It died on the on ramp to I64 at Dale,IN.  That was back in my more ignorant days.  I tried to bump start it going down that ramp fully loaded.  Needless to say it didn't get me anywhere but farther down the ramp.  I pushed miss piggy back up the ramp.  Push....grab the front brake...push grab the front brake.....didn't think I'd ever get to the top of that ramp!  There was a truck stop at that exit, so I went in and called for help to come pick me and the bike up.  Bad day!
 
Top